WordPress Audio Player Not Working – Solution

by on May 26th, 2010

I have been using WordPress Audio Player for quite a long time now to enable TechMynd guests to play MP3 audio files from TechMynd. The plugin is great. It displays simple flash audio player which can play audio track or multiple audio tracks by clicking play button. Back some days I noticed the plugin stopped working and displaying a message to upgrade flash version. I had up-to-date flash plugin but the message continued to display instead of songs. I landed on WP Audio Player troubleshooting page and noticed that the developer had mentioned following two important points.

1- Upgrade to the latest flash player which I am sure I have.
2- Use wp_footer and wp_head functions in theme files. I had these functions in my blog.

Still the player did not play the songs.

Then I thought that I might have a plugins conflict. By checking some plugins sorted the problem out. It was WP Minify Plugin. I disabled the WP Minify plugin and the problem was solved. All MP3 files were playing and the Audio Player was showing alright.

I headed over to the WP Minify Plugin page but the developer do not seem to have a contact page. Then found out his contact email in the about page and I have just emailed him about the situation.

If you are having the same problem with the Audio Player then consider these steps.

Use wp_footer and wp_head functions in footer and header files of blog theme.
Upgrade your flash player.
Disable WP Minify Plugin.
Clear blog cache files.
The problem will be solved.

Share

3 Reviews

  1. Voodoo says:

    I’ve got a problem recently with that Audio Player.

    It’s only not shown on first (main) page but it’s there when I enter a post or I go to the second page of blog…

    Anytips?

    P.S. My site is Electro Station

  2. Cassius Krendler says:

    In most cases, though, it seems to be due to the missing

    just above the in the theme’s header.php file.

  3. Minna says:

    Gee thanks! I just noticed today that wp audio player wasn’t working and searched for the reason. I even reinstalled it via FTP, but that didn’t solve the prob. It was the minify setting of the Javascript file in W3 Total Cache. Next time, I’ll check that FIRST! Thanks! I’m glad I found your website.

You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>