Framework

I just downloaded Microsoft Expression Web Superpreview which prompted me to download .net framework 3.5 SP1. Update your .net framework because you gonna need it for many latest and upcoming Microsoft products.

{ read more }